NOTICE: FORUMS MOVING

Thank you for visiting and participating in the Video.js forums. We are currently moving the forums to Stack Overflow and GitHub Issues. If you have a question or need help with Video.js, please post your question on Stack Overflow and add the tag 'video.js'. If you've found a specific bug in Video.js, please submit it in the issues tracker.

You can read more about this move on the blog.

videos not playing in firefox latest version

Eduardo Ruiz's Avatar

Eduardo Ruiz

08 Oct, 2011 11:14 PM

Hi, i really love your video player, but for some reason it only works on chrome and internet explorer. Can someone look at my test site to see what im doing wrong? in the code?
here is the link where im testing the player. http://compunetxpert.com/testvideo

Thanks really appreciated.

  1. 2 Posted by Blake Myers on 12 Oct, 2011 11:14 AM

    Blake Myers's Avatar

    i'm having the same problem ... it will work on my local network, but once i upload all the same files and make no changes to the code, it won't work. all other browsers seem just fine. only the newest firefox when used over the internet and not a local network.

    i even downloaded the files off the server to double check they uploaded right. everything checked out fine.

  2. 3 Posted by Blake Myers on 12 Oct, 2011 11:35 AM

    Blake Myers's Avatar

    i just got it figured out ... i didn't have these mime types in my .htaccess file. once i added them, firefox worked great!

    AddType video/ogg .ogv
    AddType video/mp4 .mp4
    AddType video/webm .webm

  3. 4 Posted by Eduardo ruiz on 12 Oct, 2011 12:27 PM

    Eduardo ruiz's Avatar

    So what I can do is create a htaccess file with the parameters you have, and upload this htaccess to my webserver and it should work? Where do I upload the htaccess file? On the root? Godaddy is what i'm using.

    Thanks

  4. 5 Posted by boundaryproducts on 06 Nov, 2011 05:58 PM

    boundaryproducts's Avatar

    Thanks Blake,
    Added this to my .htaccess file and it made Firefox work
    AddType video/ogg .ogv
    AddType video/mp4 .mp4
    AddType video/webm .webm

    IE9 also solved but I'll add that to the relevant post,
    thanks

  5. 6 Posted by Karin on 08 Nov, 2011 09:02 AM

    Karin's Avatar

    I have the same problem, converted all our videos to mp4 and using the videoJS plugin but the videos will not play in Firefox and IE.
    Adding the lines to htaccess had no effect.
    Does anyone have any solution to this?
    Thanks for your help.
    Karin

  6. 7 Posted by Darren on 10 Nov, 2011 12:53 PM

    Darren's Avatar

    I am also have the same issue, with latest versions of firefox, as the site i am working on is built on SharePoint and IIS 7.0 i have added the MIME type to the web.config type but this has not resolved the error. Any help would be appreciated! In IE 9 it plays and loads the flash fallback just not working firefox

  7. 8 Posted by Stephen Smith on 10 Nov, 2011 01:34 PM

    Stephen Smith's Avatar

    I can't seem to get this working in Firefox. I have tried adding the .htaccess file as above but no luck. Anyone have any more ideas??

  8. 9 Posted by fingernageldreck on 11 Nov, 2011 06:20 PM

    fingernageldreck's Avatar

    Yeah. I have GoDaddy too. Do I just upload it to the server or is there a special place to look at it? Till now I think I do not have any htaccess file... or do I? Where do I look?

  9. 10 Posted by denisebiondo on 16 Nov, 2011 03:05 PM

    denisebiondo's Avatar

    yes, i've got mine working on everything except firefox too. it's making me think that i didn't even need to convert to ogv or webm as most browsers and devices seem to be fine with the mp4. i don't have an htaccess file that i can find, but i'd really like to get this playing properly on firefox too if that will help. any advice is appreciated. thanks!

  10. 11 Posted by josh on 13 Dec, 2011 11:59 AM

    josh's Avatar

    I'm having this same problem. Only browser that doesn't work is Firefox... i've updated my .htaccess file to my server and still nothing....

  11. 12 Posted by fingernageldreck on 13 Dec, 2011 03:04 PM

    fingernageldreck's Avatar

    @Josh, @denisebiondo: Do you have the same problem locally or just once you upload it to your server? If you have problems locally check out my other thread.

    If your problem is just on the server side check out your .htaccess file. I am on a Mac and saved it with a A in front of the name to see the file (A.htaccess) and had it made in the "editor" software. Somehow when I saved the file, it added a hidden rtf to it. So, in reality, the file was called .htaccess.rtf. Once I uploaded to GoDaddy it changed and I had to manually open it on the server. Write down again all the content:
    AddType video/ogg .ogv
    AddType audio/ogg .ogg
    AddType video/mp4 .mp4
    AddType video/webm .webm
    AddType text/plain .srt

    and save it within GoDaddy's platform. This did the trick as it was saved as plain text. Since then it worked perfect and recognized it as THE .htaccess file that was needed.

  12. 13 Posted by denisebiondo on 13 Dec, 2011 05:07 PM

    denisebiondo's Avatar

    hey fingernageldreck, thanks for the info. i am not sure about the others but i actually don't see an .htaccess file on the server and i'm not sure how to create one. i think i might have to look that up and i'll look into it in the future.

    i actually did get the videos to work in firefox by fidgeting a little bit with the code and putting the FLA option as the second option. here's the line of code i put in:

    not sure if that's a perfect solution, but it is playing on firefox for me now. :)

  13. 14 Posted by fingernageldreck on 13 Dec, 2011 05:39 PM

    fingernageldreck's Avatar

    I think you don't need a flash file at all. Just use ogv, mp4 and webm and you are good to go. You can create the .htaccess file with any text editor putting in:
    AddType video/ogg .ogv
    AddType audio/ogg .ogg
    AddType video/mp4 .mp4
    AddType video/webm .webm
    AddType text/plain .srt

    You save it as plain text file and copy it to the root folder on your server (this is where your index/home.html file is. Double check it on your server, open it from there, save it again and that's it. It is important that its name is .htaccess. Nothing more. The htaccess file tells the server to recognize the formats. Thats all it does.

  14. 15 Posted by denisebiondo on 14 Dec, 2011 03:16 PM

    denisebiondo's Avatar

    thank you so much... that is very helpful! :)

  15. 16 Posted by MiracleRock2011 on 18 Dec, 2011 06:22 PM

    MiracleRock2011's Avatar

    What does: AddType mean? Right before video/ogg .ogv
    Do you just leave it saying AddType?

  16. 17 Posted by fingernageldreck on 18 Dec, 2011 08:29 PM

    fingernageldreck's Avatar

    It adds the type of the video, audio or subtitle format to the server. And yes, just leave it that way. Don't change a thing. Copy/paste all 5 lines to your new .htaccess file.

  17. 18 Posted by josh on 18 Dec, 2011 09:36 PM

    josh's Avatar

    I found that my main issue was that the format of video i was using was not compatible with firefox... :|
    I used mp4 which i thought was... so i just added multiple video sources.
    Stupid Firefox

  18. 19 Posted by MiracleRock2011 on 18 Dec, 2011 11:44 PM

    MiracleRock2011's Avatar

    I have an ogv file in there but, still no luck!

  19. 20 Posted by bartek on 13 May, 2012 03:20 AM

    bartek's Avatar

    For those people on shared Windows server:

    put the following in web.config under <system.webServer>

        <remove fileExtension=".mp4"/>
        <mimeMap fileExtension=".mp4" mimeType="video/mp4" />
        <mimeMap fileExtension=".m4v" mimeType="video/m4v" />
        <mimeMap fileExtension=".ogg" mimeType="audio/ogg" />
        <mimeMap fileExtension=".oga" mimeType="audio/ogg" />
        <mimeMap fileExtension=".ogv" mimeType="video/ogg" />
        <mimeMap fileExtension=".webm" mimeType="video/webm"/>
      </staticContent>
    
  20. 21 Posted by bartek on 13 May, 2012 03:24 AM

    bartek's Avatar

    Sorry, missed the opening , corrected below:

        <remove fileExtension=".mp4"/>
        <mimeMap fileExtension=".mp4" mimeType="video/mp4" />
        <mimeMap fileExtension=".m4v" mimeType="video/m4v" />
        <mimeMap fileExtension=".ogg" mimeType="audio/ogg" />
        <mimeMap fileExtension=".oga" mimeType="audio/ogg" />
        <mimeMap fileExtension=".ogv" mimeType="video/ogg" />
        <mimeMap fileExtension=".webm" mimeType="video/webm"/>
      </staticContent>
    
  21. 22 Posted by Tsegaye on 12 Jun, 2012 01:34 PM

    Tsegaye's Avatar

    Hey guys,

    I swapped the source elements, hence, the ogg source comes first which makes the video to play in FireFox.

                <source src="myvid.ogv" type='video/ogg'>
                <source src="myvid.mp4" type='video/mp4'>
                <source src="myvid.webm" type='video/webm'>
    

    This means that latest version that I'm using (FF 11) was ignoring mp4 and webm sources.

  22. 23 Posted by alan180 on 06 Jul, 2012 12:18 AM

    alan180's Avatar
    1. Added this to your .htaccess file:
      AddType video/ogg .ogv
      AddType video/mp4 .mp4
      AddType video/webm .webm

    2. Make sure your video file ends with ,ogv and type ogg:

        <source src="img/yourvideo.mp4" type="video/mp4" /> 
        <source src="img/yourvideo.ogv" type="video/ogg" />
    
  23. 24 Posted by ngradert on 22 Jul, 2012 10:37 PM

    ngradert's Avatar

    Edit:
    I made another test:
    I took the links to the sample-ocean-movies; they are working well!
    I think there is a coding problem with my ffmpeg commands?!?
    Can me please tell anybody which are the right ffmpeg codes to fit to firefox AND safari?!?

    Nils

    Hi all!

    Sounds good, but I have some more .htacces files on the Webserver?!
    In which folder/directory the .htacces-file do you mean?!?

    Nils

  24. 25 Posted by Casey on 27 May, 2013 03:51 PM

    Casey's Avatar

    Im having an issue with my video Js plaer not working in FF or Safari. tried cutting and pasitng the code
    (AddType video/ogg .ogv
    AddType audio/ogg .ogg
    AddType video/mp4 .mp4
    AddType video/webm .webm
    AddType text/plain .srt to my ) to that file and now im getting a browser error. Im not used to coding a .htaccess file, do i have to embed this in a other code or can i just cut and paste?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

27 Jul, 2014 07:35 PM
23 Jul, 2014 04:00 PM
22 Jul, 2014 01:12 PM
21 Jul, 2014 10:07 PM
18 Jul, 2014 10:13 PM

 

17 Jul, 2014 09:04 PM
15 Jul, 2014 02:53 PM
09 Jul, 2014 03:01 AM
08 Jul, 2014 08:01 PM
07 Jul, 2014 04:57 PM
03 Jul, 2014 04:51 PM