NOTICE: FORUMS MOVING

Thank you for visiting and participating in the Video.js forums. We are currently moving the forums to Stack Overflow and GitHub Issues. If you have a question or need help with Video.js, please post your question on Stack Overflow and add the tag 'video.js'. If you've found a specific bug in Video.js, please submit it in the issues tracker.

You can read more about this move on the blog.

VideoJS + MP4 file not working in Internet Explorer 9 on one server

David's Avatar

David

27 Apr, 2011 04:10 AM

Hello;

Following are the links to a very simple HTML page for testing the use of VideoJS & MP4 video. It is working on all browsers other than Internet Explorer 9 (HTML5 compatible) on one server:

This page (and movie) hosted on Godaddy does not let me play the movie:
http://www.kosmos-productions.com/videoMontana.html

The same page hosted on 1&1 let me play the movie:
http://www.sbaud.com/mockup/video_MontanaSbaud.html

Do you know what could be the problem?
Do I need to check some settings on Godaddy server in order for that MP4 movie to play in IE9?

I appreciate your feedback,

David

Showing the most recent page of comments. View the first page

  1. 32 Posted by Eric Warnke on 03 Apr, 2012 06:38 PM

    Eric Warnke's Avatar

    As soon as I changed preload from "auto" to "none" it started working perfectly in IE. I also have the .htaccess file modified with the right file types.

  2. 33 Posted by Blas Ingraham on 08 Apr, 2012 06:30 PM

    Blas Ingraham's Avatar

    After spending 3 days trying to figure out why my video wasn't playing in IE9, I realized that it would only play if compatibilty mode was enabled.

    I found this script at http://stackoverflow.com/questions/7542456/how-do-i-force-compatibi...

    and it worked.

    Hope this helps someone else.

  3. 34 Posted by karlina on 15 May, 2012 05:37 PM

    karlina's Avatar

    Hi all!

    I have the same issue,

    all my vids (in the html 5 video tag) play fine on my 1&1 server, but as soon as I uploaded it to my clients server IE9 won´t play any of the videos, in Chrome only one of the vids plays on my clients server...
    How the hell can that be?

    If anyone has any suggestion, please let me know, help would be really appreciated...

    Take care and thank you!

    Karlina

  4. 35 Posted by jesper on 18 May, 2012 12:22 PM

    jesper's Avatar

    Have you the right MIME type for the mp4 on the server?
    video/mp4

    /jesper

  5. 36 Posted by ScQdSmB on 05 Jun, 2012 07:15 PM

    ScQdSmB's Avatar

    Switching from 'auto' to 'none' worked for me as well.

  6. 37 Posted by Karlina on 07 Jun, 2012 05:54 AM

    Karlina's Avatar

    Mhm, I read through all the answers now, which I hadn't seen before...oops!
    What's up with the the .htaccess file I couldn't find it on my server, it is supposed to lay there when I access it through my ftp client or? Or is it somewhere on my host side I have to check? Setting from autoplay to none is no option unfortunately, I need it to be autoplay...

    Thanks for you help, it's apreciated!

    Karlina

  7. 38 Posted by Godzuke on 07 Jun, 2012 06:45 AM

    Godzuke's Avatar

    Karlina:

    The .htaccess file is a hidden file found in the root directory of your website. You would see it in your FTP client, but you may have to configure your FTP client to see hidden files....

  8. 39 Posted by Koffeedog on 13 Jun, 2012 05:48 PM

    Koffeedog's Avatar

    Karlina,

    It's not autoplay you (might) need to set to none, but preload.

    Setting preload to none instead of auto helped me with my IE9 problemos.

  9. 40 Posted by Danan on 14 Jun, 2012 04:34 PM

    Danan's Avatar

    Hey guys I had the same problem. In IE9 you need to set the poster.

    or
    { "poster": "myPoster.jpg" }
    
  10. 41 Posted by Marcus on 16 Jun, 2012 07:55 PM

    Marcus's Avatar

    here is another solution:
    http://stackoverflow.com/a/5021351

    instead of type="video/mp4" I used type="video/x-m4v" and now it works in IE9 - silly!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

17 Aug, 2014 12:53 AM
15 Aug, 2014 11:24 AM
11 Aug, 2014 05:23 PM
09 Aug, 2014 05:59 AM
31 Jul, 2014 04:52 PM

 

31 Jul, 2014 11:35 AM
30 Jul, 2014 03:25 AM
23 Jul, 2014 04:00 PM
21 Jul, 2014 10:07 PM
18 Jul, 2014 10:13 PM
17 Jul, 2014 09:04 PM